You are here: RoboHelp > Manage your project and topics > Import topics created in Microsoft Word

Import topics created in Microsoft Word

After you compose your topics in Word, you can import your files into Adobe RoboHelp. Be careful to import the files as outlined below. If you don't complete all the steps, some of your content may not format properly even after you attach a style sheet to the material in RoboHelp.

Once you import the Word content into RoboHelp, you will need to apply the project style sheet to each topic to give the entire content a unified appearance. In addition, you will need to go from topic to topic to perform one slight adjustment to your lists to remove one remnant left behind by Word.

To import topics created in Microsoft Word

  1. On the Project tab, in the Import group, click the arrow under Document, and then click Word Document.
  2. In the Import Word Document dialog box, navigate to the file you want to import, and then click Open.
  3. In the Content Settings dialog box, make sure all the check boxes are cleared, and then click Next.
  4. In the Import dialog box, under Word Document, click Edit.
  5. In the Conversion Settings dialog box, under Word Document Settings, double-click Paragraph, and then click Heading 1.
  6. In the RoboHelp Style list, click Heading 1.
  7. Select the Pagination (Split into topics based on this style) check box.
  8. Under Word Document Settings, in the Paragraph list, click Heading 2.
  9. In the RoboHelp Style list, click Heading 2.

Repeat steps 8 and 9 to map any other headings in your document.

  1. Under Word Document Settings, click Normal, and then make sure the RoboHelp style is set to Source or Normal.
  2. Under Word Document Settings, click Other Settings.
  3. Select the Convert Word list to check box, and make sure the conversion list is set to HTML List.

Import the lists as mentioned in steps 11 and 12. If you don't, your lists won't be formatted correctly, and Word will add a bunch of style codes into RoboHelp that will create conflicts that can require editing the HTML code to correct.

  1. Click OK, and then click Finish.

To apply the style sheet to each topic imported from Word to RoboHelp

Make sure you have created a project style sheet before completing this task.

To apply the style sheet… Do this…
To a single topic

On the Edit tab, in the CSS group, click the Assign Stylesheet list, and then click the name of your style sheet file.

To multiple topics See the Apply a style sheet to multiple topics page in this Help system.

To apply the correct formatting to lists initially created in Word

  1. Open a topic that you imported from Word into RoboHelp.
  2. Select a numbered or bulleted list on the page.
  3. On the Edit tab, in the Styles group, click the Paragraph Styles list, and then click (none).
  4. Repeat steps 2 and 3 for each list in the current topic.
  5. Repeat steps 1, 2, and 3 for each topic in the project.